20.52. kb-00051: Image-deploy requires a CentOS repo

20.52.1. Knowledge Base Article: kb-00051

20.52.2. Description

When using Image-deploy inside of sledgehammer, the system requires at least one repo to function. Most of the time this works fine or if the quickstart guide is followed.

If neither the centos install isos are downloaded nor the package-repositories parameter points to valid repositories, then the install of the image-deploy tools will fail.

20.52.3. Solution

Add the centos-8-install or centos-7-install isos to the system.

To do this:

drpcli bootenvs uploadiso centos-7-install

or

drpcli bootenvs uploadiso centos-8-install

This choice of centos-7 or centos-8 is based upon the version of sledgeahammer you are using. Sledgehammer is currently centos-7 based, but will move to centos-8 by default in the next release, v4.6.0.

20.52.4. Additional Information

Additional resources and information related to this Knowledge Base article.

20.52.4.1. See Also

20.52.4.2. Versions

All versions.

20.52.4.3. Keywords

sledgehammer, image-deploy, install failure

20.52.4.4. Revision Information

KB Article     :  kb-00051
initial release:  Thu Nov 19 23:02:47 CST 2020
updated release:  Thu Nov 19 23:02:47 CST 2020